import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<span id=\\\"MyId\\\">|\\G),?([^<>,]+)";
final String string = "<html>\n"
+ "...\n"
+ "<span id=\"MyId\">string 1,string 2,string 3,strin4,string5,string6</span>\n"
+ "...\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}