re = /(?:<span id=\"MyId\">|\G),?([^<>,]+)/m
str = '<html>
...
<span id="MyId">string 1,string 2,string 3,strin4,string5,string6</span>
...
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end