const regex = /(?:<span id=\"MyId\">|\G),?([^<>,]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<span id=\\"MyId\\">|\\G),?([^<>,]+)', 'gm')
const str = `<html>
...
<span id="MyId">string 1,string 2,string 3,strin4,string5,string6</span>
...
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}