$re = '/(?:<span id=\"MyId\">|\G),?([^<>,]+)/m';
$str = '<html>
...
<span id="MyId">string 1,string 2,string 3,strin4,string5,string6</span>
...
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);