#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Error in script "(.*)" on line (\d+)"
Local $sString = "Processing script file: "/Users/johndoe/Projects/test.nsi" (UTF8)" & @CRLF & _
"Invalid command: Foo" & @CRLF & _
"Error in script "/Users/johndoe/Projects/test.nsi" on line 5 -- aborting creation process"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")