using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Error in script ""(.*)"" on line (\d+)";
string input = @"Processing script file: ""/Users/johndoe/Projects/test.nsi"" (UTF8)
Invalid command: Foo
Error in script ""/Users/johndoe/Projects/test.nsi"" on line 5 -- aborting creation process";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}