import re
regex = re.compile(r"Error in script \"(.*)\" on line (\d+)")
test_str = ("Processing script file: \"/Users/johndoe/Projects/test.nsi\" (UTF8)\n"
"Invalid command: Foo\n"
"Error in script \"/Users/johndoe/Projects/test.nsi\" on line 5 -- aborting creation process")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")