// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"Error in script "(.*)" on line (\d+)"#).unwrap();
let string = "Processing script file: \"/Users/johndoe/Projects/test.nsi\" (UTF8)
Invalid command: Foo
Error in script \"/Users/johndoe/Projects/test.nsi\" on line 5 -- aborting creation process";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}