import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Error in script \"(.*)\" on line (\\d+)";
final String string = "Processing script file: \"/Users/johndoe/Projects/test.nsi\" (UTF8)\n"
+ "Invalid command: Foo\n"
+ "Error in script \"/Users/johndoe/Projects/test.nsi\" on line 5 -- aborting creation process";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}