import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+[^\\s/]*/\\w{2}\\b.*?)\\s*(\\d+\\.\\d{2})$";
final String string = "10/04 Some brief description blah blah blah 45.00\n\n"
+ "VJ../VI Another stupid brief description 1000.00\n"
+ "11/13 This is another description LO05.13";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}