import re
regex = re.compile(r"^(\w+[^\s/]*/\w{2}\b.*?)\s*(\d+\.\d{2})$", flags=re.MULTILINE)
test_str = ("10/04 Some brief description blah blah blah 45.00\n\n"
"VJ../VI Another stupid brief description 1000.00\n"
"11/13 This is another description LO05.13")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")