// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+[^\s/]*/\w{2}\b.*?)\s*(\d+\.\d{2})$").unwrap();
let string = "10/04 Some brief description blah blah blah 45.00
VJ../VI Another stupid brief description 1000.00
11/13 This is another description LO05.13";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}