re = /^(\w+[^\s\/]*\/\w{2}\b.*?)\s*(\d+\.\d{2})$/m
str = '10/04 Some brief description blah blah blah 45.00
VJ../VI Another stupid brief description 1000.00
11/13 This is another description LO05.13'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end