#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "refs/tags/([0-9]+)\.([0-9]+)\.([0-9]+)(?:-([0-9A-Za-z-]+(?:\.[0-9A-Za-z-]+)*))?(?:\+[0-9A-Za-z-]+)?" & @CRLF & _
""
Local $sString = "refs/tags/0.0.1-alpha" & @CRLF & _
"refs/tags/0.0.1-alpha1" & @CRLF & _
"refs/tags/140.02.1-FINAL" & @CRLF & _
"refs/tags/1.2.3" & @CRLF & _
"refs/tags/1.2.3000000.FINAL" & @CRLF & _
"refs/tags/1.0002.3..FINAL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")