const regex = /refs/tags/([0-9]+)\.([0-9]+)\.([0-9]+)(?:-([0-9A-Za-z-]+(?:\.[0-9A-Za-z-]+)*))?(?:\+[0-9A-Za-z-]+)?
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('refs\/tags\/([0-9]+)\\.([0-9]+)\\.([0-9]+)(?:-([0-9A-Za-z-]+(?:\\.[0-9A-Za-z-]+)*))?(?:\\+[0-9A-Za-z-]+)?
', '')
const str = `refs/tags/0.0.1-alpha
refs/tags/0.0.1-alpha1
refs/tags/140.02.1-FINAL
refs/tags/1.2.3
refs/tags/1.2.3000000.FINAL
refs/tags/1.0002.3..FINAL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}