import Foundation
let pattern = #"""
refs/tags/([0-9]+)\.([0-9]+)\.([0-9]+)(?:-([0-9A-Za-z-]+(?:\.[0-9A-Za-z-]+)*))?(?:\+[0-9A-Za-z-]+)?
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
refs/tags/0.0.1-alpha
refs/tags/0.0.1-alpha1
refs/tags/140.02.1-FINAL
refs/tags/1.2.3
refs/tags/1.2.3000000.FINAL
refs/tags/1.0002.3..FINAL
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}