package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`refs/tags/([0-9]+)\.([0-9]+)\.([0-9]+)(?:-([0-9A-Za-z-]+(?:\.[0-9A-Za-z-]+)*))?(?:\+[0-9A-Za-z-]+)?
`)
var str = `refs/tags/0.0.1-alpha
refs/tags/0.0.1-alpha1
refs/tags/140.02.1-FINAL
refs/tags/1.2.3
refs/tags/1.2.3000000.FINAL
refs/tags/1.0002.3..FINAL`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}