re = /refs\/tags\/([0-9]+)\.([0-9]+)\.([0-9]+)(?:-([0-9A-Za-z-]+(?:\.[0-9A-Za-z-]+)*))?(?:\+[0-9A-Za-z-]+)?
/
str = 'refs/tags/0.0.1-alpha
refs/tags/0.0.1-alpha1
refs/tags/140.02.1-FINAL
refs/tags/1.2.3
refs/tags/1.2.3000000.FINAL
refs/tags/1.0002.3..FINAL'
# Print the match result
str.match(re) do |match|
puts match.to_s
end