# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ *–.*//g;t' <<< "Yes – No – No – No
Yes – No – No & No – No
Yes Yes – No & No – No
Yes – No – No & No
Yes – No
Yes – No – No"