#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " *–.*"
Local $sString = "Yes – No – No – No" & @CRLF & _
"Yes – No – No & No – No" & @CRLF & _
"Yes Yes – No & No – No" & @CRLF & _
"Yes – No – No & No " & @CRLF & _
"Yes – No" & @CRLF & _
"Yes – No – No"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)