re = / *–.*/
str = 'Yes – No – No – No
Yes – No – No & No – No
Yes Yes – No & No – No
Yes – No – No & No
Yes – No
Yes – No – No'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result