$re = '/ *–.*/';
$str = 'Yes – No – No – No
Yes – No – No & No – No
Yes Yes – No & No – No
Yes – No – No & No
Yes – No
Yes – No – No';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;