use strict;
my $str = 'Yes – No – No – No
Yes – No – No & No – No
Yes Yes – No & No – No
Yes – No – No & No
Yes – No
Yes – No – No';
my $regex = qr/ *–.*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";