#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:^|.*,)([^,\n]*),.*\1(?:,|$)).*$"
Local $sString = "value1,value2,value2,va-lu4,value 6" & @CRLF & _
"value1,value2,value3,va-lu4,value 6,value1" & @CRLF & _
"value1,value2,value3,va-lu4,value 6" & @CRLF & _
"value1,value1,value8,va-lu4,value 6" & @CRLF & _
"value1,value2,value8,va-lu4,value 6" & @CRLF & _
"value1,value2,value3,va-lu4,value 6,value 6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")