re = /^(?!(?:^|.*,)([^,\n]*),.*\1(?:,|$)).*$/m
str = 'value1,value2,value2,va-lu4,value 6
value1,value2,value3,va-lu4,value 6,value1
value1,value2,value3,va-lu4,value 6
value1,value1,value8,va-lu4,value 6
value1,value2,value8,va-lu4,value 6
value1,value2,value3,va-lu4,value 6,value 6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end