using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:^|.*,)([^,\n]*),.*\1(?:,|$)).*$";
string input = @"value1,value2,value2,va-lu4,value 6
value1,value2,value3,va-lu4,value 6,value1
value1,value2,value3,va-lu4,value 6
value1,value1,value8,va-lu4,value 6
value1,value2,value8,va-lu4,value 6
value1,value2,value3,va-lu4,value 6,value 6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}