import re
regex = re.compile(r"^(?!(?:^|.*,)([^,\n]*),.*\1(?:,|$)).*$", flags=re.MULTILINE)
test_str = ("value1,value2,value2,va-lu4,value 6\n"
"value1,value2,value3,va-lu4,value 6,value1\n"
"value1,value2,value3,va-lu4,value 6\n"
"value1,value1,value8,va-lu4,value 6\n"
"value1,value2,value8,va-lu4,value 6\n"
"value1,value2,value3,va-lu4,value 6,value 6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")