#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)([^\w]+)"
Local $sString = "100,,,,,00001000,111,,,,,1111,,,,111,,1,1110055425648hgffghgff,---n00)));.; ;;"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)