package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)([^\w]+)`)
var str = `100,,,,,00001000,111,,,,,1111,,,,111,,1,1110055425648hgffghgff,---n00)));.; ;;`
var substitution = ","
fmt.Println(re.ReplaceAllString(str, substitution))
}