import Foundation
let pattern = #"([^\w]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"100,,,,,00001000,111,,,,,1111,,,,111,,1,1110055425648hgffghgff,---n00)));.; ;;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)