$re = '/([^\w]+)/im';
$str = '100,,,,,00001000,111,,,,,1111,,,,111,,1,1110055425648hgffghgff,---n00)));.; ;;';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;