use strict;
my $str = '100,,,,,00001000,111,,,,,1111,,,,111,,1,1110055425648hgffghgff,---n00)));.; ;;';
my $regex = qr/([^\w]+)/imp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";