# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0|[^\na-zA-Z0-9+]+//gm;t' <<< "0(31)2345678
1(80)0123456"