import re
regex = re.compile(r"^0|[^\na-zA-Z0-9+]+", flags=re.MULTILINE)
test_str = ("0(31)2345678\n"
"1(80)0123456")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)