$re = '/^0|[^\na-zA-Z0-9+]+/m';
$str = '0(31)2345678
1(80)0123456';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;