use strict;
my $str = '0(31)2345678
1(80)0123456';
my $regex = qr/^0|[^\na-zA-Z0-9+]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";