re = /^0|[^\na-zA-Z0-9+]+/m
str = '0(31)2345678
1(80)0123456'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result