#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<name>\D*?) (?<grade>(A)?(B)?(C)?(D)?(E)?(FX)?(F)?)(?<ex>(-+)|(\++))?"
Local $sString = "abelone A--------" & @CRLF & _
"andersine A+" & @CRLF & _
"bo A" & @CRLF & _
"bosse A++" & @CRLF & _
"anton FX-" & @CRLF & _
"antonina FX+" & @CRLF & _
"anders A+" & @CRLF & _
"konstantin FX" & @CRLF & _
"william F" & @CRLF & _
"andreas A+" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")