import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<name>\\D*?) (?<grade>(A)?(B)?(C)?(D)?(E)?(FX)?(F)?)(?<ex>(-+)|(\\++))?";
final String string = "abelone A--------\n"
+ "andersine A+\n"
+ "bo A\n"
+ "bosse A++\n"
+ "anton FX-\n"
+ "antonina FX+\n"
+ "anders A+\n"
+ "konstantin FX\n"
+ "william F\n"
+ "andreas A+\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}