import re
regex = re.compile(r"(?<name>\D*?) (?<grade>(A)?(B)?(C)?(D)?(E)?(FX)?(F)?)(?<ex>(-+)|(\++))?", flags=re.MULTILINE)
test_str = ("abelone A--------\n"
"andersine A+\n"
"bo A\n"
"bosse A++\n"
"anton FX-\n"
"antonina FX+\n"
"anders A+\n"
"konstantin FX\n"
"william F\n"
"andreas A+\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")