// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<name>\D*?) (?<grade>(A)?(B)?(C)?(D)?(E)?(FX)?(F)?)(?<ex>(-+)|(\++))?").unwrap();
let string = "abelone A--------
andersine A+
bo A
bosse A++
anton FX-
antonina FX+
anders A+
konstantin FX
william F
andreas A+
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}