using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<name>\D*?) (?<grade>(A)?(B)?(C)?(D)?(E)?(FX)?(F)?)(?<ex>(-+)|(\++))?";
string input = @"abelone A--------
andersine A+
bo A
bosse A++
anton FX-
antonina FX+
anders A+
konstantin FX
william F
andreas A+
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}