import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<Building>\\b\\d+)\\s(?<Street>.*(?:#\\d+|No Unit Number))\\s(?<City>\\b.+),\\s(?<State>.{2})\\s(?<Zip>\\d{5}\\b)";
final String string = "1234 Street Name Unit #225 Harpers Ferry, VA 12345\n"
+ "5547 No Unit Number Jackson Hole, WY 12345\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}