const regex = /(?<Building>\b\d+)\s(?<Street>.*(?:#\d+|No Unit Number))\s(?<City>\b.+),\s(?<State>.{2})\s(?<Zip>\d{5}\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<Building>\\b\\d+)\\s(?<Street>.*(?:#\\d+|No Unit Number))\\s(?<City>\\b.+),\\s(?<State>.{2})\\s(?<Zip>\\d{5}\\b)', 'gm')
const str = `1234 Street Name Unit #225 Harpers Ferry, VA 12345
5547 No Unit Number Jackson Hole, WY 12345
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}