using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AAABC
ABABC";
string input = @"34sdf, 434ssdf, 43fef, sdfsfs,
sdf4 sfs, 34ssdf, 43fef,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}