re = /AAABC
ABABC/m
str = '34sdf, 434ssdf, 43fef, sdfsfs,
sdf4 sfs, 34ssdf, 43fef,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end