$re = '/AAABC
ABABC/m';
$str = '34sdf, 434ssdf, 43fef, sdfsfs,
sdf4 sfs, 34ssdf, 43fef,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);