// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)AAABC
ABABC").unwrap();
let string = "34sdf, 434ssdf, 43fef, sdfsfs,
sdf4 sfs, 34ssdf, 43fef,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}