package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)AAABC
ABABC`)
var str = `34sdf, 434ssdf, 43fef, sdfsfs,
sdf4 sfs, 34ssdf, 43fef,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}