# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*?[A-Z0-9]$)[A-Z][\w-]*$/./igm;t' <<< "a123
a
a_"